Broken Marker Images

Incident Report for Geopointe

Postmortem

For unknown reasons, Cloudflare stopped caching marker images correctly. Cloudflare is used between Salesforce and our servers for security and simplicity purposes. It helps keep data secure when we have to use our server for calculations. Among those calculations is the image generation of the map markers.

Map markers now only use Cloudflare to route the image request; we no longer store cached images there. That fixed the problem, and should prevent a re-occurrence.

If you or a member of your team is still seeing broken markers in your Geopointe environment, empty your web browser cache; it’s likely the bad images got cached locally. After you clear your cache, you should see markers again. If you continue to have problems, please email us at help@geopointe.com.

Posted Aug 19, 2022 - 16:20 EDT

Resolved

If you or a member of your team are continuing to see broken marker images, make sure you clear your browser image cache. After that, you should start to see marker pins again.

Thank you for your patience with this inconvenience.
Posted Aug 19, 2022 - 16:12 EDT

Monitoring

We have identified a caching error in one of our security service providers. The caching has been disabled and markers are appearing normally again.

Our development team will continue to monitor for degraded performance caused by the lack of caching and if an alternative solution will be necessary. If you notice any significant decreases in data set load times, please contact help@geopointe.com.
Posted Aug 18, 2022 - 12:26 EDT

Update

We are continuing to investigate this issue.
Posted Aug 17, 2022 - 17:28 EDT

Investigating

We are hearing multiple reports of data set markers showing as broken images in the editor and not showing up on the map at all. We are investigating the root case of the problem and hope to have a resolution soon.

If you need a resolution sooner, there is a workaround: edit the markers in some way (add/remove icons, change the color slightly) and re-save the data set. We understand this is not a sustainable resolution, and will be working to find a better one as quickly as possible.
Posted Aug 17, 2022 - 14:00 EDT
This incident affected: Data Sets, Data Set Editor, and Map Data Searches.